Question

.zapierapprc resetting

  • 14 December 2020
  • 3 replies
  • 112 views

Userlevel 1

I am building a zapier app which is using the vm2 module. But for some reason, zapier decides to exclude many files from the module causing the app to error.

I am trying to add

"includeInBuild": [
    "node_modules/vm2/*",
    "node_modules/vm2/lib/*.js",
  ]

to the .zapierapprc file but it doesn’t work.

Everytime I link my app to a zapier project, the .zapierapprc goes back to default, deleting those lines.
If I just add the lines and runs zapier build, it doesn’t include the files either.

What am I doing wrong.


This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

3 replies

Userlevel 7
Badge +9

Generally `link` is used infrequently, when you need to associate a new local project with a project that already exists on the Zapier platform.  You only need to run it once.  Once you’ve called link and have the .zapierapprc file, you can just run push.  You won’t need to use link again.  Doing do will blow your your file away, and that’s what you’re running into.

https://zapier.github.io/zapier-platform/cli#link

In the docs: “This command generates a .zapierapprc file”.  

 

For other community members who find this, more context:  Running link is also not required if you started your new project in your local CLI environment with the `init` command.  Running the `register` and `push` command will create the .zapierapprc file and will create a new project on the platform side.  

 

Userlevel 7
Badge +12

@Powerleech - Which version of the Zapier CLI are you using?

Userlevel 1

@Powerleech - Which version of the Zapier CLI are you using?

I am using 

"zapier-platform-core": "10.1.2"