Best answer

"Zap Could Not Be Switched On" error


Hello,

I created a REST hook trigger for an app, then I created a Zap for it.

All Zap creation steps pass.

But, when enabling it, I receive an email saying "Zap Could Not Be Switched On".

Also, if I make a request to the hook URL, it replies with 410.

What's wrong ?

Thanks

icon

Best answer by Tiana_Goomeo 6 July 2022, 13:42

View original

4 replies

Userlevel 7
Badge +9

What do the logs show? If a trigger perform step returns an error on the first time it runs Zapier will turn the Zap off. So I’d look to make sure the subscribe perform is working at Zap enablement time, and the rest hook trigger’s perform method isn’t returning an error, thrown or otherwise. 

What do the logs show?

If you mean Zapier’s Zap history : nothing.

If you mean mine :

  • no error when receiving a POST request, hookUrl is present in body and I reply with 201 status and empty body ;
  • trying to make a POST request to said URL will return 410 status and "please unsubscribe me!" in body.

If a trigger perform step returns an error on the first time it runs Zapier will turn the Zap off. So I’d look to make sure the subscribe perform is working at Zap enablement time, and the rest hook trigger’s perform method isn’t returning an error, thrown or otherwise. 

Turns out I receive no request to the perform method.

I also just noticed that I receive two requests to the subscribe method : the first one provides a hook URL starting with https://hooks.zapier.com/hooks/standard/ while the second one starts with https://zapier.com/hooks/standard/.

Thanks

Hello, Zapier
 

I am facing the same problem as @Tiana_Goomeo .

 

I have created a REST hook trigger for my "New User Zap",
All zap creation steps are successfully done without any error.

But, When I turn ON the zap I got the subscribe zap "hookUrl", and when I refresh the current page it shows zap is OFF.

I got this mail

 

“ Unfortunately your Zap New User Zap could not be switched on. Please try enabling it again, and if you still experience issues, get help. “

Also, I'm getting two hookURL at the time of zap turn ON
First hookUrl: https://hooks.zapier.com/hooks/standard/12*****5/2d*****************************3/
Second hookUrl: https://zapier.com/hooks/standard/12*****5/2d*****************************3/

When I hit both hookUrl I got this message "please unsubscribe me!"
In the end zap does not insert data in my google sheet



Also update me when the problem is fixed.

Hello,

Turns out the issue was :

Zap was paused with error message: Response needs to be JSON, form-urlencoded or parsed in middleware

So, making the Subscribe method return an empty JSON object instead of nothing, fixed the issue.

However, I had to contact support in order to get that error log, it would have been nice to be able to access it directly as the Zap creator.

Thanks

Reply