Best answer

Mindbody Private App

  • 22 January 2020
  • 10 replies
  • 3708 views

Userlevel 2
Badge

I'm stepping over my line of experience as I do regularly...

Trying to build a private app for Mindbody Online (https://developers.mindbodyonline.com/PublicDocumentation/V6#authentication) but the authentication is killing me.

Somebody told me he's also done it with Session Auth, but I'm fouling that up somehow. Pointers would be greatly appreciated, or if someone had time to do a video call for an hour or so, I'd gladly pay for you time.

Thanks!


icon

Best answer by BowTieBots 22 January 2020, 21:31

@Robert_Segelquist

Session Auth is the correct type. The initial request returns the "staffUserToken" that you need in the rest of your API calls. API Auth wouldn't allow for that storage.

It looks like the API is looking for the username and password in the URL Params instead of the body. Change step 2 to look like this:

image.pngIf you get any more errors can you post the error log from Monitoring please. It gives a lot for detail than Zapier's error response in app.

image.png


View original

This post has been closed for comments. Please create a new post if you need help or have a question about this topic.

10 replies

Userlevel 4
Badge +4

@Robert_Segelquist

Can you post what your current authorization code so we can troubleshoot where the error might be.


Userlevel 4
Badge +4

@Robert_Segelquist Try the following things:

Change your inputs to the following example and pay close attention to the case as the values are case sensitive.

image.png

Set up step 2 so it looks like this:

  • URL Params should be empty

image.pngimage.png

Set up step 3 so it looks like this:

  • URL Params and Request Body should be empty

image.pngFor Easy Reference here are all the values:

  • Username {{bundle.authData.Username}}
  • Password {{bundle.authData.Password}}
  • Api-Key {{bundle.authData.Api-Key}}
  • SiteId {{bundle.authData.SiteId}}
  • Content-Type application/json
  • authorization {{bundle.authData.accessToken}}

Let me know if you have any more questions.


Userlevel 7
Badge +10

Paging @ikbelkirasan who's an expert at such things!


Userlevel 7
Badge +11

@Robert_Segelquist You should click on a data point in the chart to get more details about what happened at that point in time.

If you're still getting the error, make sure you don't set the Authorization header when you call /usertoken/issue because this might be the reason why that error occurred. You can check the chart for when 4xx errors occurred and check if the Authorization header was set when it was requesting a new access token. Hope this helps!


Userlevel 7
Badge +8

Hey @Robert_Segelquist, we just wanted to check-in to see if you were able to get things solved here and if any of the previous suggestions helped to solved your issue. If so, you can mark that it "answered your question". If not, let us know and we can continue looking into this with you!


Userlevel 4
Badge +4

@Robert_Segelquist

Session Auth is the correct type. The initial request returns the "staffUserToken" that you need in the rest of your API calls. API Auth wouldn't allow for that storage.

It looks like the API is looking for the username and password in the URL Params instead of the body. Change step 2 to look like this:

image.pngIf you get any more errors can you post the error log from Monitoring please. It gives a lot for detail than Zapier's error response in app.

image.png


Userlevel 2
Badge

Authorization is set up as follows:

image.pngimage.pngimage.pngGetting Error:

image.pngAnd I have created functional webhooks with just the API and siteID, so I'm just messing something up somewhere along the line.


Thanks @BowTieBots and @AndrewJDavison_Luhhu


Userlevel 2
Badge

@BowTieBots I set all of it up and tested it with both my developer credentials and personal log in credentials and got an error both times

image.png

Thanks for stepping through this with me.


Userlevel 2
Badge

@BowTieBots Should it be API Auth or Session Auth?


Userlevel 2
Badge

I'm not getting any more detailed information than this.

image.pngBut it's still giving me an error