Question

Error on Authorising my App with Zapier App using oauth2

  • 17 March 2021
  • 5 replies
  • 24 views

Hi 

I am setting up an App on Zapier

I have selected the oauth2 method, added the client key and client secret.

Added the authorise and token request route

Verified all the workflows in Postman, all the routes and workflows are working fine

but when in testing tab, I try Sign In to ‘App Name’ 

I get the error without any proper information


5 replies

In addition to the above information

I am using the Laravel Valet on my local environment

Userlevel 7
Badge +8

You have probably seen this but some common reasons can be found here: https://stackoverflow.com/questions/17690803/node-js-getaddrinfo-enotfound/44255808 

 

It would be difficult to look into it further without seeing the code. 

You have probably seen this but some common reasons can be found here: https://stackoverflow.com/questions/17690803/node-js-getaddrinfo-enotfound/44255808 

 

It would be difficult to look into it further without seeing the code. 

But I am getting error when I am redirected to zapier after authorize 

 

https://zapier.com/dashboard/auth/oauth/return/App129449CLIAPI/?code=def50200a6b985d1b4bbc99fcf4f5bb15c5dc3fecd970a8b9183e70e6a5f903d5bc9dc4490e73c6f2dbbf51da391d6be74ba66d538546622962d341925ba1b6074c0139039e290951fbed9b90a8bb8e357b7c539bd73cfdddd488adf8aca08df85f9bea7a0b25e3335babafa018546442efd45e12784070270494fea013057abf7835dd743996db174e2bfc9dd0838b488c22475e440c7be05a4970d706dcca6d3b5f591399e1bc3d67cb0aff6f39977fb5ec8e1938ce78a00262a159d29808969ca2935b4ed73287e273238d483aaf6179b988f24ae11266712ae9c036bbcf639602f59c2dc18724f5032de0b737cca99435a346783c0219998c0fca693354b951b026319ac0e4b6356dad76033e815426bbede6afa722a93ddfac97c3bdfd9285a83b4aaf1f7db23710f275854e9f7308814155ed7744bbba3d15feb36f17ead83eb4ec73524ddb48db7989407656d0ec4034fef35a1580ad56b7f62728d07121abcd585b7f3d33d8367f7d2a097f9ded3c08daf7473cd49431cfea73dcf97c71c3893697918&state=1616044042.132797253159

 

 

Their is not specific code, I have just installed Laravel Passport in my application, 

Created a client in my application and used those cridentials in Zapier App

 

 

 

Userlevel 7
Badge +11

Hi @Zach Johnson - Are you sure that your domain name is publicly available? I tried to make a DNS lookup but it seems to be unavailable. I guess it’s only configured on your machine?

 

Hi @Zach Johnson - Are you sure that your domain name is publicly available? I tried to make a DNS lookup but it seems to be unavailable. I guess it’s only configured on your machine?

 

It was only configured on my system, for development purpose .. 
I deployed it live and everything started working, 

for some reason, Zapier was unable to verify keys with my local environment ..

 

Reply