Question

We’re having trouble loading 'Trigger Rule' data


Userlevel 1

Hello, 

When I creart a zap on the step one I am getting the error:

We’re having trouble loading 'Trigger Rule' data

Cannot read property 'forEach' of undefined

Could you help me to solve it? 

Thanks. 


14 replies

Userlevel 7
Badge +7

Hey there! What app are you using as your trigger, and would it be possible to share more details (e.g. screenshot) of the error you’re seeing please?

Userlevel 1

Hello, 

I am using WooCommerce https://prnt.sc/saqxrr

Userlevel 7
Badge +6

@Dev-woocommerce 

Checking in to see if you are still encountering any issues with this Zap or if you are squared away! Please let us know either way as we want to make sure you’re all sorted here!

Userlevel 7
Badge +10

Hi @Dev-woocommerce!

Since this was a little while ago, I wanted to check in to see if you’d managed to solve this or whether you still needed help here. Please let us know!

Hi there, i am having the same issue. Any ideas?

Userlevel 7
Badge +6

Hi @boulmpos ,

Thanks for reaching out! I can see that you are working with Chelsey in Support on this issue- I will let them continue to help troubleshoot to get you squared away!

I am also having that problem. 

My goal is to zap a customer’s email to convertkit when the order is shipped. Is that possible?

Userlevel 7
Badge +8

Hi all, here’s a screenshot of what @boulmpos figured out to make the Zap work:

https://cdn.zappy.app/272f27cab9946156af82a7c484c037ab.png

 

@Susie and @Dev-woocommerce could you take a look and see if you still need help?

@steph.n  Can you tell me the solution. i have same problem.

I am having the same issue, this just started. How did you resolve this?

Userlevel 7
Badge +10

Hi @jlo2552!

It looks like we'll have to dig deeper into this one, so I'm going to escalate this to our Support team. They'll help you resolve this issue in a timely fashion :)

Hello,I have also same issue. I checked REST API but it doesn’t work yet.
How can I solve this issue?

I too am having this issue. Even when putting “Order create” in as a custom value like Steph described.

To be more specific, when I use “Order create” I can get past that part, but then get the error 

List Resource response parse failed.

 

When I look this up, I found some WooCommerce Docs that say:

Your WooCommerce store’s WooCommerce REST API isn’t responding with valid JSON, so your task has been halted.

 

When I get here, I’m lost.

 

Please Advice. 

Userlevel 1

Hi everyone,

Often this kind of error means that there is some kind of plugin or security firewall interfering with your WooCommerce website’s REST API endpoints.

Please contact us (WooCommerce Zapier Support) so that we can review the logs and identify what could be causing your issue.

Thank you,

James
OM4 Software
Creators of WooCommerce Zapier

Reply