Question

Problems with the 'Tag added to conversation' trigger event for Intercom

  • 17 April 2020
  • 8 replies
  • 186 views

I have problems with the 'Tag added to conversation' trigger event for Intercom. I don't see any of my conversation tags as the trigger. I only see what appears to be random dummy tags.

 

Does anyone know the solution to this?

 

Thx

M

 

 


8 replies

Userlevel 6

*Rant alert* I honestly hate Intercom tags. They got it all wrong in my opinion - They have tags that apply to conversations and users and accounts and leads - Yet it’s the same object, so searching for them in Intercom is a nightmare, and they always get assigned to the wrong thing! The person who came up with their tagging database was either evil, ignorant or both.  :grin:

 

Rant over

 

So my first question is:

  1. are you searching for the tag on the right object

And my second is

  1. Are you sure the tag has been added to the correct object in Intercom?

 

Haha. It works great with Productboard and their native integration.

 

To your two questions:

  1. Yes
  2. Yes

Still can't see the tags. All the tag that Zapier shows me is in fact not even any messages that was tagged in the first place. :/

 

What do you recommend ?

Userlevel 6

If you are seeing dummy pages, it suggests to me that you’re looking a some kind of staging version of Intercom - Can you check your domain and permissions, and let me know if this changes things?

@Saastronomical 

We only have one environment and are for the moment not using any staging environment.

Not sure what you mean when you say domain and permissions?

I have full admin permission and our domain is musiversal.com?

 

Here is a bit more context:

Our tag on Intercom

 

How it appears on Zapier

 

All the tagged messages in the conversations are just random messages that isn't tagged.

 

Hope this helps.

 

Do you know what the issue might be?

 

Thanks

M

Userlevel 7

Hi @Martin Quach!

 

I think that there might be a few things at play here. First of all, where the Zap says Tag A, Tag B, etc., that’s just a way of denoting the difference between the samples found. For example if you were using a trigger with emails, it would say ‘Email A, Email B’. 

 

In terms of why the samples in the trigger are not conversations that have tags on them, that’s a bit more unusual. I’m not super familiar with Intercom, but sometimes with samples we have to call a list of recent (general) examples, rather than ones that specifically match the trigger conditions. Could I trouble you to try setting up your Zap and then turning it on and testing it by tagging a conversation? If it would be a Zap with a lot of actions and you don’t want to build the whole thing without checking the trigger (which is understandable!) then I recommend adding just one action (eg send an email to yourself) and testing it that way. 

 

Could you give that a go and see how you get on? Thanks!

Hi @Danvers 

 

Thanks for your reply.

 

It triggers on any tags, which is not too surprising, as there there is not option for specifying the tag that I’d like it to trigger on. 

Can you confirm that that’s something to do with the integration configured on Intercom’s side?

 

The ‘message body’ that I’m sending from Intercom to Slack seems to be the first message in the thread with the customer. In this case, it’s the chat opener. See below. 

Can you also confirm that that’s something to do with the integration configured on Intercom’s side?

 

I presume the next steps is to work with Intercom for a fix? Do you have a way for me to get in touch with the team/person responsible for the Zapier integration at Intercom?

 

Thanks

Martin

Userlevel 7

The Intercom integration is actually one of the ones that maintained by Zapier, so we’re the ones to speak to in this case(!)

 

In terms of your first question, we do have a feature request for the ability to specify which tag to trigger on and I’ve added you to that which 1) lets the team know how many users would like to see that addition and 2) means that we’ll send you an email address if it becomes a reality. 

 

In terms of your second question about the message body being only the first message, I’m not 100% familiar with the intercom integration, so I’m going to escalate this to the Support Team who can take a look at your Zap and let you know if there’s another field you can use or a workaround. Someone will be in touch via email as soon as possible. 

I’m also trying to get the second reply as the message body from the conversation. The first reply is their choice from a yes/no question.

I’m trying to find out why the user initiating the conversation doesn’t appear as any attribute value in the conversation so that I can add that information to a Salesforce case or do a lookup on it.

Reply