Solved

How do I fix (#100) Page Public Metadata Access requires either app secret proof or an app token on my zaps?

  • 19 March 2020
  • 18 replies
  • 4008 views

I cant turn on my zaps because of this issue: (#100) Page Public Metadata Access requires either app secret proof or an app token

icon

Best answer by Danvers 29 April 2020, 17:32

Hi folks! I wanted to post an update to let you know that we’ve investigated this bug and it looks like it’s resolved itself. Just to re-iterate, this bug is where folks are using Facebook Pages and having trouble finding samples and specifically see the error (#100) Page Public Metadata Access requires either app secret proof or an app token

View original

18 replies

Userlevel 5
Badge +5

Hi @crown ,

Thanks for reaching out- sorry you are encountering this error!

You have stumbled across a current bug with the Facebook Lead Ads integration. I have added you as an impacted user, so once resolved you will be notified. 

As a workaround, here are a couple things to try:

  1. Disconnect Zapier from your Facebook Business Integrations

 

  1. Once that's done, go back to your Connected Accounts page - https://zapier.com/app/connections - and click Reconnect on your Facebook Lead Ads Account. Then see if your page shows up.


It also can't hurt to double check you have all the permissions listed here, and have a look at other help topics on this page, which is about the most comprehensive help page we have for any app on Zapier.

Let us know if those do the trick!
 

ERROR: (#100) Page Public Metadata Access requires either app secret proof or an app token

How to troubleshoot this?

Userlevel 7
Badge +10

@kamila Perfect, thanks for letting us know 🙂

@Danvers never mind! just found it. thanks!

@Danvers thanks for your reply.

 

I haven’t received any reply from Support Team other than the “Thank you for activating your Zapier Community account!” email.

I have checked spam as well.

If there was an email sent to me with the reply, would you please ask the support team to resend it?

Thank you!

Userlevel 7
Badge +10

Hi @kamilla, I’m really sorry that you’re running into an issue with your Facebook Zap. I can see that you got in touch with the Support Team and that they’ve already got back to you. It’s best to continue the conversation with them via email as they’ll be able to take a closer look at your Zap with you. 

 

If for any reason that you can’t see our email to you, please could you check your spam folder and if that doesn’t help, please try searching  your whole email inbox for emails ending in ‘@zapier.com’

Is there any zapier technical support email or phone number that I can call? 

I’ve been having this same issue for days and really need it fixed urgently.

Any article will help, but couldn’t find any.

 

It was working perfectly for a whole year and suddenly today this shows up as I’m trying to customize my lead:

  • (#100) Page Public Metadata Access requires either app secret proof or an app token

 

Userlevel 7
Badge +8

Hi @ChoiceLocal!

I see that you’ve written to our Support team and they have responded with some questions. Please continue the conversation there, since they’re able to dig into your Zaps :)

I’m still having this issue right now on many of my Zaps

Userlevel 7
Badge +10

Hi folks! I wanted to post an update to let you know that we’ve investigated this bug and it looks like it’s resolved itself. Just to re-iterate, this bug is where folks are using Facebook Pages and having trouble finding samples and specifically see the error (#100) Page Public Metadata Access requires either app secret proof or an app token

Userlevel 7
Badge +10

Hi @hivehero and @CSS! Issues like this are really tricky to trouble shoot via the community as they generally need someone to take a close look at your Zaps and permission settings in Facebook.

 

The best thing to do here would be to send as many details as possible to the Support Team using the contact form. I’m sorry to send you somewhere else, but the Support team will be able to dive into this with you to find out if it’s related to the set up of the Zap/permissions in Facebook or if it’s something else. 

@Danvers - I too am having the same problem. 

Summary: I setup 

 

Here’s a walk-thru of me setting it up. There is NO SOUND. 

https://www.loom.com/share/0d602368d1324cd38f654eb8fc498c0a

 

My permissions: 

https://shared.cmox.co/v1uD5pq5

https://shared.cmox.co/QwuKvmJk

 

What can I try?

Hi guys, I’m facing the same error with my Facebook Page that is connected with Zapier. I’ve tried reconnecting the Facebook Pages on Zapier and resetting the connection with Facebook. But still receiving the same error. What should I do? Please help… 

Userlevel 7
Badge +10

Hi @bryanjlaz thanks for your message and I’m sorry that you’re having this issue with your Zaps. Can I double check with step of the Zap you’re seeing an error with? The message ‘(#100) Page Public Metadata Access requires either app secret proof or an app token’ is one that we’re seeing with Facebook Pages (rather than Lead Ads). Could you confirm that so we can be sure that we’re on the same page? Thanks!

Hey guys.. I’m having the same exact issue on 3 zaps I have setup with the same ad account and fb page. It had been working fine for over 6 months at least and just stopped all of a sudden on 3/18/20. I have all admin permissions, tried reconnecting several times but seem to still have the issue.. Any advice? Thank you..

 

Bryan

Userlevel 7
Badge +10

Hi there @Pranayg93 and @iBAN! If you’re using Facebook Lead Ads, it has a lot of different permission settings, and if one of them isn't correct it will stop new leads from being passed to Zapier.

 

Even if you’ve previously set up a successful connection with Zapier, something can change and you’ll need to reset those permissions. Could you please take a look at this help guide and work through all of the steps there to see if that solves the issue. 

 

@iBAN if you’re using a different app, could you let us know? Thanks! 

Hi, I am facing the same issue. It's related to Facebook lead gen ads.  Please help

Userlevel 5
Badge +5

Hi @iBAN ,

Thanks for reaching out and sorry you are running into this error! It sounds like you’re running into an access issue that may be due to current permission settings. 

Can you share what apps you are trying to connect (sounds like a social media page)? That will allow us to dig deeper and get you squared away!

 

Reply