Solved

Firestore data to Excel.... but how ?

  • 3 December 2020
  • 6 replies
  • 32 views

Hi Everyone,

I have been trying to tweak Zapier for the last couple of hours but without success. And I thougt I might ask around before giving up.

I have a firebase collection with several documents inside it. I’m looking for a way to send the fields from each documents to excel rows. 

 

Exemple:

In Firestore I have a collection named People which contains several documents:

   Document 1

  • name: John
  • age: 34
  • city: London

   Document 2

  • name: Laura
  • age: 27
  • city: Paris

 

And I want to get every document in Excel:

name age city
John 34 London
Laura 27 Paris

 

Is Zapier able to do that ?

 

Many thanks for reading :)

Jul

icon

Best answer by Troy Tessalone 3 December 2020, 16:53

That’s because you’ve mapped all the data points everything to Column A

Make sure your Excel file has headers for each of the columns in Row 1. (e.g. Name, Age, City)

Excel help articles for Zapier: https://zapier.com/apps/excel/help

View original

6 replies

Userlevel 7
Badge +6

FYI: Zaps work best for new records going forward when the Zap is turned ON.

If you’re trying to backfill existing records, look into a manual export/import or try https://transfer.zapier.com.

Firebase Trigger: New Document within a Firestore Collection

 

Thanks Troy for the reply.

I get it, Zap works best for new records, and that’s fine with me :)

My issue is that right now, zapier sends all my fields in one cell. In my exemple each field (name, age, city) goes to a different column.

With Zapier, everything goes to column A, in a unique cell , like this:

column A
name age city

 

Userlevel 7
Badge +6

Can you please provide a screenshot of how the data comes thru on the trigger step?

Here you have my trigger, which looks fine.

Problem is with the action, everything goes to Col$a , i have no option to change that.

Then the result in excel, all the fields are put together in the same cell.

Userlevel 7
Badge +6

That’s because you’ve mapped all the data points everything to Column A

Make sure your Excel file has headers for each of the columns in Row 1. (e.g. Name, Age, City)

Excel help articles for Zapier: https://zapier.com/apps/excel/help

Awesome, thank you !

Reply