Question

Discord bot reached maximum number of servers


Userlevel 2

I've tried numerous times to make a connection with Discord, but everytime I try to do so and grant alle the requested rights to the zapier bot, it returns an error message saying that “This bot has reached the maximum number of servers". I'm not sure what it means by that.

The only thing the documentation advices me to do, is allow the bot to set webhooks. Since the bot hasn't even managed to show up, I've temporarily given @everyone the right to manage webhooks. When that also didn't work I switched of all the permissions the zapier bot requested, save the webhook permission. And even that didn't work. 

I'm running out of ideas. How can I solve this problem?
 


134 replies

Userlevel 7
Badge +9

Apologies for the delay in updating this thread. We understand this bug is super frustrating, and I assure you we’re working diligently to get this fixed with Discord. We’ve got a verification request that is still pending with them. We’ve followed up and are essentially waiting for the Discord team to approve our request.

While I don't have an ETA on resolution, you'll definitely be notified as soon as we hear back that it's been fixed. I’m hoping that it’s sooner than later (for everyone’s sake!).

I’ve added the following people as affected users:

@Chasin @Kikedv @HutchXC @captainxoco @Arwyn - No More Robots @Krown @DYSM @Derek W. @Oliviabee @alexhillman @Timm_ @nitrous @CSNPLogan @iamdave @montana552 @cofo @pfp7 @Snarli @LeSauvage @radarforest @Fuzzedtv @Fractal @zap-noob @AkaMickG @kimbap @Drasgüm @BREAKFADER @Golden Gorilla @andy7753 @ZappyDev @ashtray54 @Social Capital Gainer @Otooo @sly433 @thiagomatos @brutus @Qmodo 

So sorry for the inconvenience, and thanks for your patience as we work to resolve this.

Userlevel 7
Badge +7

Hi there @chunkyRice - Thanks for reporting this bug. We’ve alerted the team of this error and they’re currently investigating this issue. You’ll be contacted directly once we implement a fix. Sorry for the trouble!

Userlevel 2

@Troy Tessalone The developer document you linked to may contain the answer for developers who understand what it says. The reason I use zapier, is because I am not a developer. I tried to read it, but found it incomprehensible.

If you could direct us to a specific file we need to look for, tell us what line of text we're supposed to change and what we need to change it into, we might be able to solve the problem.

Userlevel 7
Badge +5

@Liz_Roberts Can you please escalate this to Support?

I’ve seen a handful of these questions being asked within the last 24 hours, which makes me think it’s not an isolated issue with a particular user or account.

I was able to replicate the issue myself.

Userlevel 7
Badge +9

I have added these folks to the affected users list, to be notified when this is resolved: @Repeat @pyroplumeria @Folalbii @Ain Waltz @Thaliruth @marcelguerero 

@Thaliruth you’re absolutely correct. That’s what we’re in the process of doing with Discord :) Looks like they’ve got a high volume of requests coming in. I’ll be as relieved as all of y’all when this gets resolved!

Userlevel 7
Badge +5

@Juan & @bloodrush545 - consolidating your posts within this thread as this is the same bug. I have added you both to the bug report as impacted users so that you will be contacted directly via email with any update!

Userlevel 1

Thank you @Liz_Roberts 

Userlevel 1

Thank you everyone for looking into this.

 

Depending on your range of how long you’ve seen these reports it might have something to do with the requirement of Gateway Intents. This change looks like it took place on September 24th.

 

https://discord.com/developers/docs/change-log

Userlevel 1

@cofo its been almost 2 weeks. Quite frustrating…

Userlevel 1

I do not know if this is the right place to ask but I am having troubles adding the Zapier bot to the Discord that I am an Admin/Owner of.  Every time I authorize and complete the Captcha I get: http://prntscr.com/uyp2w6 

 

Does anyone know how I can fix this if I am doing something wrong?  I have looked on the internet and YouTube but I do not see anyone else with this problem..?

Userlevel 1

Hi @Danvers@Liz_Roberts  I have been facing this exact same problem too so please add me as well, these recent Discord regulations are really frustrating but they are apparently made to sort out certain issues,

Anyway i have been able to verify my own business bot which  .. as it’s taking too long for Zapier to verify its’ Bot through Discord here is what i have done .. i got it verified in less than these (4-5) business days they mention:

  • Joined Discord’s own Discord server https://discord.com/invite/discord-developers
  • Went to the #verification-help
  • in there you can post questions or comments after 10 minutes from joining that server then according to one of the messages there i learned that Discord sent an email to the Bot’s owner’s email .. the one that is used for the main Discord account in my case .. that link put me on the right track to actually verify the bot .. they basically just need to have a passport photo ID or official ID stating the owner’s name as written on the ID on their system.
  • After 2 days i received an email saying my bot has been verified and all .. after it got verified i still got the same messages and turned out that i needed to make my bot settings like this https://s.advaith.io/switches then got it whitlisted as well to turn that option on by opening a support ticket which just told me to add something in my bot code that’s all it took to fix it.
  • it’s all in there in Discord’s own server which is posted in discord’s guidelines by the way .. just head to ( #verification-faq ) and ( #verification-help ) there.

 

Please do these and don’t let this wonderful bot die with discord, its my favorite and better than any presumed alternatives out there 🥺.

Thank you.

Userlevel 7
Badge +5

Hi @Amenadiel - sorry you are encountering this issue! I have added you as an impacted user so that you will be notified when there is an update. 

Userlevel 1

Hi @Amenadiel - sorry you are encountering this issue! I have added you as an impacted user so that you will be notified when there is an update. 

 

Thanks you

Userlevel 7
Badge +5

@Loreljia @Ver @tempestcards @Carlo Giu @architek1 - sorry you all are encountering this as well! I have added you all to the report as impacted users so that you will receive updates via email (be sure to keep an eye on your spam folder as well, just in case)!

same boat, still awaiting on fix.

Can you add me @Liz_Roberts? Thanks!

Hello @Liz_Roberts. I am also having this issue. Please notify me as well.

Having the same issue, please add me as well, thank you! @pfp7 

Userlevel 7
Badge +5

@Liz_Roberts and here

@Liz_Roberts 

Hi Liz, please add me to the email report as well. I am experiencing the same issue.
Thanks in advance!

I got the same exact problem.

same problem here

Same issue. Please let me know.

Thank you,

Userlevel 1

I keep getting this error trying to add my account.

@Loreljia @Ver @tempestcards @Carlo Giu @architek1 - sorry you all are encountering this as well! I have added you all to the report as impacted users so that you will receive updates via email (be sure to keep an eye on your spam folder as well, just in case)!

 


Please add me as well. Thank you.

Reply