Solved

Discord bot reached maximum number of servers


Userlevel 2

I've tried numerous times to make a connection with Discord, but everytime I try to do so and grant alle the requested rights to the zapier bot, it returns an error message saying that “This bot has reached the maximum number of servers". I'm not sure what it means by that.

The only thing the documentation advices me to do, is allow the bot to set webhooks. Since the bot hasn't even managed to show up, I've temporarily given @everyone the right to manage webhooks. When that also didn't work I switched of all the permissions the zapier bot requested, save the webhook permission. And even that didn't work. 

I'm running out of ideas. How can I solve this problem?
 

icon

Best answer by rghazali 29 October 2020, 17:33

Hi all! Thanks so much for your patience, and so sorry for the inconvenience. As mentioned above, we were going through the process of getting our bot approved for use on Discord. I’m happy to be able to announce that we’ve been approved, so you should be able to once again create Discord Zaps. We’ll send out the email to notify users that this is resolved shortly.

Please let us know if you have any further questions!

View original

137 replies

Userlevel 1

I keep getting this error trying to add my account.

Userlevel 7
Badge +5

Common Problems with Discord on Zapier

Article: https://zapier.com/help/doc/common-problems-with-discord-on-zapier

"Error: Missing Permissions"

To connect with Zapier, your bot user will need to have the "Manage Webhooks" permission in Discord: https://discordapp.com/developers/docs/topics/permissions

Userlevel 1

In the previous screen I authorized it for all the permissions. Is this something I have to configure on the Discord end first before I can authorize Zapier to tie into the server.

Userlevel 1
Badge

I have a similar problem, what trying to connect it shos a message thas syas “this bot has reached the maximum number of servers”. Nothing more, and I cant connect.

 

Userlevel 2

@Troy Tessalone The developer document you linked to may contain the answer for developers who understand what it says. The reason I use zapier, is because I am not a developer. I tried to read it, but found it incomprehensible.

If you could direct us to a specific file we need to look for, tell us what line of text we're supposed to change and what we need to change it into, we might be able to solve the problem.

Userlevel 7
Badge +5

@Liz_Roberts Can you please escalate this to Support?

I’ve seen a handful of these questions being asked within the last 24 hours, which makes me think it’s not an isolated issue with a particular user or account.

I was able to replicate the issue myself.

Userlevel 7
Badge +5

@Liz_Roberts and here

Userlevel 7
Badge +7

Hi there @chunkyRice - Thanks for reporting this bug. We’ve alerted the team of this error and they’re currently investigating this issue. You’ll be contacted directly once we implement a fix. Sorry for the trouble!

Userlevel 7
Badge +5

@Juan & @bloodrush545 - consolidating your posts within this thread as this is the same bug. I have added you both to the bug report as impacted users so that you will be contacted directly via email with any update!

Userlevel 1
Badge

Thank you @Liz_Roberts 

Userlevel 1

Thank you everyone for looking into this.

 

Depending on your range of how long you’ve seen these reports it might have something to do with the requirement of Gateway Intents. This change looks like it took place on September 24th.

 

https://discord.com/developers/docs/change-log

Userlevel 1

Hi, i have the same issue, can you help me to connect bot with zapier please or alert maintenance team please ?

 

thanks.

Userlevel 7
Badge +5

Hi @Amenadiel - sorry you are encountering this issue! I have added you as an impacted user so that you will be notified when there is an update. 

Hello,

could you please notify me too? I have the same error with linking zapier to discord.

Thank you and have a great day :3

Userlevel 1

Hi @Liz_Roberts could you add me too? Same problem here. Been trying to sync Zapier with my Discord from this past weekend countless times doing endless things without any success. Tried to reach Zapier support at Twitter and by email and well, same happened. Nothing (not even a “we are aware and we're working on it please hold on :)”

 

Good thing thou is finding Im not the only one with this issue as Google also didnt show anything really relevant…

 

Will we get an email with any update of when the situation could be solved? Much appreciated!

V.

Userlevel 1

Hi @Amenadiel - sorry you are encountering this issue! I have added you as an impacted user so that you will be notified when there is an update. 

 

Thanks you

Hi @Liz_Roberts Please notify me as well, I am experiencing the same issue using the discord bot connection. Please notify when the issue has been fixed or needs to be re-tested. Thank you!

Hello @Liz_Roberts , could I please be notified as well?

I’m running into this issue as well.

Userlevel 7
Badge +5

@Loreljia @Ver @tempestcards @Carlo Giu @architek1 - sorry you all are encountering this as well! I have added you all to the report as impacted users so that you will receive updates via email (be sure to keep an eye on your spam folder as well, just in case)!

Userlevel 1

I do not know if this is the right place to ask but I am having troubles adding the Zapier bot to the Discord that I am an Admin/Owner of.  Every time I authorize and complete the Captcha I get: http://prntscr.com/uyp2w6 

 

Does anyone know how I can fix this if I am doing something wrong?  I have looked on the internet and YouTube but I do not see anyone else with this problem..?

I’m am having the same issue. I made the same bot for a different server earlier today and no issues and now I can’t get this one verified :O

Notify as well same issue. 

I am also having this issue. If I can be added to the reports of fixes it would be great. 

Hello @Liz_Roberts . Please also add me to the email report, as our team was just considering using Zapier for this integration, but it’s not working. Thanks!

Reply