Solved

authentication failed: Got 401 calling GET https://www.exemple.com/wp-json/wc-zapier/v1/ping, triggering auth refresh.

  • 28 April 2020
  • 21 replies
  • 1797 views

Userlevel 1

Hi everyone,

I receive this error message when i try to make a Zap for Woocommerce.

Someone have the solution at this problem?

authentication failed: Got 401 calling GET https://www.exemple.com/wp-json/wc-zapier/v1/ping, triggering auth refresh.

 

icon

Best answer by steph.n 8 June 2020, 19:49

Hi @The Darl 

It’s been a while but we wanted to check back on this issue. I saw you were able to get in touch with Cameron and Nick from Zapier Support. We think the solution mentioned would be worth sharing to the rest of the community so here it is:

Thanks for following up about this and for the additional information about what you've tried. From the steps you've followed and the explanation of what worked, I think it's the way your WooCommerce instance is hosted as well that's causing the problem. Unfortuately this isn't something we can help with : / We can't see your VPS/Server setting and it's outside the scope of our knowledge/support.

You might get a hold of the person who set up the hosting for you or the hosting company itself?

View original

21 replies

Userlevel 7
Badge +6

Hi @Martint ,

Thanks for reaching out- sorry you are running into a 401 error here!

I see that you have reached out to Support on this issue which is perfect as they can dig into our logs and your specific Zap to help troubleshoot. They will be in touch just as soon as they can!

Please let us know if you have any additional questions- happy to help!

Hi @Liz_Roberts!

I’m getting the same error on this website, could you help me? Thanks! :) 
 

 

Userlevel 7
Badge +8

Hi @The Darl 

It’s been a while but we wanted to check back on this issue. I saw you were able to get in touch with Cameron and Nick from Zapier Support. We think the solution mentioned would be worth sharing to the rest of the community so here it is:

Thanks for following up about this and for the additional information about what you've tried. From the steps you've followed and the explanation of what worked, I think it's the way your WooCommerce instance is hosted as well that's causing the problem. Unfortuately this isn't something we can help with : / We can't see your VPS/Server setting and it's outside the scope of our knowledge/support.

You might get a hold of the person who set up the hosting for you or the hosting company itself?

Hi,

I am getting same error while I am trying to connect to zapier. I don’t get any popup to allow or accept permissions. My account is an admin account and username, password is correct. what else do I need to do to make it functional. Please help me to connect to zap.

 

Userlevel 7
Badge +8

Hi @amita - Thanks for letting us know. I’ve gone ahead and escalated your ticket to our Support team for further assistance. Thanks for your patience!

Userlevel 7
Badge +6

Hi @amita ,

Circling back to make sure you are squared away on this Zap!

I see Cameron from Support relayed that the WordPress integration can only connect to WordPress installs where the admin dashboard's URL ends in /wp-admin/. It’s tricky as it is possible to change this default, and if it has been changed Zapier will fail to connect.


I see he advised verifying if your admin dashboard URL ends in /wp-admin/ and using the non-beta version of the WordPress integration to see if that did the trick!

Please let us know if you are running into any issues or if we can be of any additional help!

Hello,

Can someone please help me out here?

 I am getting the exact same error and my dashboard url has ‘/wp-admin’ .

 

PLEASE HELP

Nithin

Userlevel 7
Badge +10

@Nithin!

Looks like you’ve got a great conversation going with our Support team and they’re helping you out with this! I see a response from them about 2 hours ago. If you have any further questions you can reply to that thread :)

Hi , I’m having the same issue here , does anyone found a solution yet ? Thanks 

Userlevel 7
Badge +6

Hi @Khalil Az ,

Thanks for reaching out!

Were you able to verify if your admin dashboard URL ends in /wp-admin/ and try using the non-beta version of the WordPress integration? If that doesn’t do the trick, our Support team is best suited to help here as they can look at your specific configuration to see what’s going on. You can contact them here: Zapier Support. 

I’m having the same issue, and yes, my admin dashboard URL ends in /wp-admin/.
Weirdly I can connect using the “Wordpress Legacy” app.

Does this have the same functionality as the normal Wordpress app? I wouldn’t know as I’ve never been able to connect with it.

Userlevel 7
Badge +11

Hi @BEEF DOCTOR 

 

Broadly speaking, we don’t recommend that you use Legacy apps because as the app you’re connecting to changes, different triggers and actions may stop working. Also, newer versions of apps often deal with bugs that were known to exist in older (Legacy) versions. 

 

For WordPress specifically, the newer (curent) version of the integration has a number of actions that the Legacy version doesn’t have including: Find Post, Create User and Update Post. 

 

WordPress can be really tricky to connect to as there are so many different things to account for. I’d recommend first going through the trouble shooting guide (Common Problems with WordPress) and if that doesn’t help, contact the Support Team using the Get Help form as they’ll be able to dig into things more with you. 

Userlevel 6
Badge +6

Check if your

I’m having the same issue and I think it may have to do with having 2FA using Wordfence plugin. What’s the best way to connect to wordpress and maintain connection when I use 2FA? Thanks!

I’ve just figured out why I was running into this.

I’m hosting on WP Engine.  It didn’t work for me in my dev environment, but when I set it up to test in production it worked just fine.

In that the same plugins are not installed in production yet, there might be a deeper issue here, or its just how the xml-rpc is handled in dev environment.

Hi out site is on wordpress.com and getting same error. Where do we start with fixing this problem?? Thank you!

Hi everyone,

I just got the same error trying to zap my wordpress, any solutions to try?

 

authentication failed: Got 401 calling POST https://inspirededu.org/wp-json/zapier/v1/token, triggering auth refresh.

 

Tried deactivating plugins but no luck.

 

Kind regards

Hi everyone,

Same error to me too… 

I have a product launch on Sunday, I absolutely need to automate the creation of user accounts between ThriveCart and Wordpress...

Yesterday everything was working fine during the first implementation, and today nothing works anymore... Thanks for helping me please!

 

“We hit an error adding your new account
authentication failed: Got 401 calling POST https://formation.labellewivine.com/wp-json/zapier/v1/token, triggering auth refresh.”

Userlevel 7
Badge +6

Hi @Benjamace @Carlos.Lazaro @londonstreetcompany !

Sorry you all are running into this! If you are still encountering issues, give these steps a try:

  • Double check that the Zapier plugin is installed on your WordPress site? You can find this here.
    Once that's been installed, make sure you're entering your WordPress domain in the authentication screen without any of the login slugs. More specifically, that should look like this: "https://example.com"

 

  • If your username isn't connecting, it can help to use your email address instead. If this still shows the same kind of error, there might be a security plugin that's preventing apps like Zapier from connecting to your Wordpress site. Read more here.

If those don’t seem to do the trick and you are still encountering issues, you can contact our Support team here so that they can troubleshoot further!

Userlevel 1

Running into this same issue. Running WordPress with Plesk, Wordfence installed but disabled. Any definitive answers on how to resolve?

Thanks,

Tim

Userlevel 7
Badge +8

Hi @timspencer - Thanks for writing in to us! I’m afraid the latest update was from our staff member, Liz. If you are still having troubles our Support team may be reached here. Sorry for the troubles!

Reply